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 December 1, 2008 

Dear customer, 
 
Vaisala hereby wants to inform you about an error found in DigiCORA MW31 sounding software 
(this software is used also in MW21). It is related only to ozone soundings that are made either 
with RS92-SGP, RS92-SGPW, RS92-SGPD or RS92-AGP radiosondes. 
 
In an ozone sounding, ozone concentration is measured by the radiosonde at about one second 
interval. The measurements are integrated to obtain accumulated ozone. Thus at the end of 
sounding, accumulated ozone amount is known from surface up to the balloon burst altitude. To 
obtain the total ozone amount in the atmosphere, the ozone amount above the burst altitude is 
estimated and added up to the measured accumulated ozone amount. This total ozone value is 
reported as 'Total ozone from sondeprofile (COL1)' in NILU (Nasa Ames 2160) message. 
 
Version 3.12 of DigiCORA MW31 software reports only the measured cumulative ozone as the 
total ozone. The estimated residual ozone beyond the top of sounding is not included in the total 
value. This is a deviation from the practice applied in other DigiCORA software versions. 
 
Vaisala apologizes for any inconvenience this fault may cause to you. Closer details about the 
issue as well as work-arounds and solutions are given in the following. 
 
 
1. SUMMARY 
 
1.1 Error applies to  
 
Ozone soundings made with RS92-SGP, RS92-SGPW, RS92-SGPD or RS92-AGP radiosonde 
models together with any of the following DigiCORA Sounding software versions: 
 
- 3.12  
- 3.51 if updated from version 3.12 
- 3.52 if updated from version 3.12 or if updated first from 3.12 to 3.51 and then to 3.52  
 
 
1.2 Symptoms 
 
Total Ozone value as reported by DigiCORA system is clearly lower when compared to a value 
obtained from another measurement system e.g., from a Dobson-Brewer spectrophotometer.  
 
 
1.3 Cause 
 
The ozone computation routine, 'Ozone-OIF92' in software version 3.12 does not compute 
residual ozone and reports measured cumulated ozone as the Total Ozone 
 
1.4 Status 
 
The error exists only in version 3.12 and it has been corrected in later versions.  
 
Notice however that the error remains when updating the DigiCORA Sounding software from 
version 3.12 to versions 3.51 or 3.52. See paragraph 2.3 for further information about such 
updates. 
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2. DETAILED DESCRIPTION 
 
2.1 Total ozone computation 
 
Total ozone value, usually in Dobson units, represents the total ozone column in the 
atmosphere. When using a radiosonde for the observation, the ozone is measured up to the 
highest point of sounding and the amount of ozone in the atmosphere above is estimated. Total 
ozone is obtained using the following formula: 
 

Total ozone = Measured accumulated ozone + Residual ozone, where 
 

Residual ozone = 7.8899 * Ozone concentration at the last measured level 
 
Version 3.12 of the DigiCORA software reports the Measured accumulated ozone as Total 
ozone. i.e., the Residual ozone is missing.  
 
 
2.2 Ozone computation routine a.k.a. ozone script 
 
When using DigiCORA MW21 or MW31 and RS92-SGP or RS92-SGPW or RS92-SGPD or 
RS892-AGP radiosonde, ozone data is computed by the 'Ozone-OIF-92' ozone script.  
 
The script is stored in the Parameters.dc3db file together with other system parameters. When a 
sounding is made the used script is copied to the produced sounding data file. When simulating 
a sounding the script in the sounding data file is used, not the one in Parameters.dc3db. 
 
The source code of the script is open and it can be viewed and modified by the user. The original 
ozone script of each software version handles the total and residual ozone as shown in the 
following table: 
 
                  
Version             Reported total ozone   
3.12                  = measured ozone 
3.51 when updated from 3.12   = measured ozone 
3.52 when updated from 3.12, directly or via 3.51 = measured ozone 
3.61 when updated from any earlier version             = measured + residual ozone 
3.51 when installed from scratch  = measured + residual ozone 
3.52 when installed from scratch  = measured + residual ozone 
 
 
The Total Ozone value is stored in each sounding data file (sounding database) in a parameter 
called 'IntegratedOzone'. This parameter can be found in 
/SYSPAR/Triggering/Data/OzoneParams. 
 
When computed, the residual ozone value is stored in each sounding data file as 
'ResidualOzone' in /SYSPAR/Triggering/Data/OzoneParams. 
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2.3 DigiCORA software updates 
 
If the software has been updated from version 3.12 to version 3.51 or 3.52, measured 
accumulated ozone is still reported as Total Ozone. This is because the update procedure 
doesn't overwrite the ozone script when updating from 3.12 to 3.51 or 3.52. If however, version 
3.51 or 3.52 is installed from scratch i.e., the original version 3.12 is first removed completely or 
it was never installed, the ozone script functions correctly. 
 
When updating to version 3.61, the ozone computation routine is always replaced with a new 
version to correct the error discussed here. The error can reappear only if the user manually 
returns the erroneous ozone script into the system. 
 
 
3. HOW TO VERIFY 
 
3.1 How to verify the correctness of the script in the currently installed software 
 
To find out if the script in the currently installed software is correct and that the future soundings 
will be computed correctly, proceed as follows: 
 
1)  Start DigiCORA software and then in 'Tools' menu select 'System Parameters…'. This will 

start the DBManager software. 
 
2)  In DB Manager, select 'Connect' in 'File' menu. 
 
3)  On the left pane, navigate to 'SYSPAR/Triggering/Ozone-OIF92/Calc_Ozone'. 
 
4)  On the left pane, click on 'Calc_Ozone' and then on the right pane double click on 

'ScriptSource'. The script source code opens. 
 
5)  Scroll down the listing to the last procedure. The procedure should look like this: 
 

PROCEDURE WriteTotalToDb 
   TotalCount -= 1 
   IF TotalCount < 0.5 
      SETDBDOUBLE(TotalPath$, "IntegratedOzone", Data+Residual) 
      SETDBDOUBLE(TotalPath$, "ResidualOzone", Residual) 
      TotalCount = 5 
   ENDIF 
ENDPROCEDURE.  

 
 The two lines starting with SETDBDOUBLE should look exactly as shown above.  
 
 If they do, it means that the ozone script is correct and that the Total Ozone in further 

soundings is computed correctly. No further action on the installed software is necessary.  
 
 If they don't, see paragraph 4.1 below. 
 
6) Click 'Cancel' to close the script listing, then exit the DBManager by selecting 'Exit' in 'File' 

menu.  
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3.2 How to verify the correctness of sounding data files (archived soundings) 
 
To find out if the Total Ozone value in past soundings was computed correctly, proceed as 

follows: 
 
1)  Click 'Start' in the Windows taskbar and select 'Run…'.  
 
2)  In the window that opens, type 'dbmanager' and click 'OK'. DBManager software starts. 
 
3)  In DBManager click 'File' and then 'Open'. Then select the sounding data file and click 

'Open'. 
 
4)  When the file is open in DBManager, navigate to 'SYSPAR/Triggering/Data/OzoneParams'.  
 
5)  On the left pane, click on 'OzoneParams'. 
 
6)  Check if in the right pane, in the list of values there is a parameter called 'ResidualOzone'.  
 
 If ResidualOzone exists, it means that the Total Ozone is computed correctly. No further 

action on that particular sounding data file is necessary.  
 
 If ResidualOzone doesn't exist, see paragraph 4.2 below.  
 
7)  Close the DBManager selecting 'Exit' in 'File' menu. 
 
 
4. RESOLUTION 
 
4.1 System software 
 
If you have followed the instructions in 3.1 above and have verified that the ozone script in your 
current software installation needs to be updated proceed as follows: 
 
 
4.1.1 If you are currently using version 3.12 then either  
 
a) upgrade to version 3.61 or  
 
b) update the ozone script in the 'Parameters.dc3db' database (see 5.2. below) 
 
If you have modified the original ozone script to fit your special purposes and want to have those 
modifications also in the new version, the modifications shall be added to the new script 
manually.  
 
 
4.1.2 If you are currently using version 3.51 or 3.52 updated from version 3.12 then either 
 
a) upgrade to version 3.61 or  
 
b) update the ozone script in the 'Parameters.dc3db database' (see 5.2. below) or 
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c) remove the sounding software completely and reinstall. If you want to save your sounding 
data files in the DigiCORAIII\Archive folder, move them temporarily to another location. Using 
Add/Remove programs in Windows' Control Panel, first remove Metgraph and Stanag options if 
they are installed and then remove the DigiCORA software. Check if the DigiCORAIII folder is 
deleted and if not, delete it manually. Then reinstall the version 3.51 or 3.52.  
 
Note that in this option the system parameters are set to their default values and that you may 
need to manually edit them to suit your needs. 
 
If you have modified the original ozone script to fit your special purposes and want to have those 
modifications also in the new version, the modifications shall be added to the new script 
manually.  
 
 
4.2 To correct your old archived data files proceed as follows: 
 
If you have followed the instructions in 3.2 above and have verified that the sounding data file 
needs to be updated proceed as follows: 
 
Update the ozone script in the original sounding database file (see 5.3. below). Then run a 
simulation. This way the whole database can be updated and a new NILU message generated 
with correct Total Ozone value. 
 
 
5. FURTHER GUIDANCE 
 
5.1 How to get the new script 
 
The new script can be downloaded from  
 

www.vaisala.com/soundings 
 

Alternatively you can contact Vaisala Helpdesk to obtain the script by email or CD.  See 
paragraph 6 for contact details. 
 
 
5.2 How to copy the new script to Parameters.dc3db file 
 
Caution: Carefully follow the below instructions when changing the Parameters.dc3db. 
 
1)  Open the new ozone script in Notepad. Then select 'Select All' in 'Edit' menu (or type Ctrl-A). 

Then select 'Copy' in 'Edit' menu (or type Ctrl-C). The new script is copied to clipboard. Close 
the Notepad. 

 
2)  Start DigiCORA software and then in 'Tools' menu select 'System Parameters…'. 

DBManager software is started. 
 
3)  In DB Manager, select 'Connect' in 'File' menu. 
 
4)  On the left pane, navigate to 'SYSPAR/Triggering/Ozone-OIF92/Calc_Ozone'. 
 

http://www.vaisala.com/soundings
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5)  On the left pane, click on 'Calc_Ozone' and then on the right pane double click on 
'ScriptSource'. The script source code opens. 

 
6)  Right click on the text area and select 'Select all'. Right click again and select 'Paste'. The 

new script is copied from clipboard to the database overwriting the old script. 
 
7)  Check that the last procedure in the script listing looks like this: 
 

PROCEDURE WriteTotalToDb 
   TotalCount -= 1 
   IF TotalCount < 0.5 
      SETDBDOUBLE(TotalPath$, "IntegratedOzone", Data+Residual) 
      SETDBDOUBLE(TotalPath$, "ResidualOzone", Residual) 
      TotalCount = 5 
   ENDIF 
ENDPROCEDURE.  

 
8)  Click 'OK' to exit the script listing. 
 
9)  Close DBManager and DigiCORA software by choosing 'Exit' is 'File' menu. After this change 

the system will compute the Total Ozone value with the residual ozone included. 
 
 
5.3 How to copy the new script to archived sounding data file (file with extension .dc3db) 
 
1)  Open the new ozone script in Notepad. Then select 'Select All' in 'Edit' menu (or type Ctrl-A). 

Then select 'Copy' in 'Edit' menu (or type Ctrl-C). The new script is copied to clipboard. Close 
the Notepad. 

 
2)  Click 'Start' in the Windows taskbar and select 'Run…'. 
 
3)  In the window that opens, type 'dbmanager' and click 'OK'. DBManager software starts. 
 
4)  In DBManager click 'File' and then 'Open'. Then select the sounding data file and click 

'Open'. 
 
5)  When the sounding data file is open in DBManager, navigate to 'SYSPAR/Triggering/Ozone-

OIF92/Calc_Ozone'. 
 
6)  On the left pane, click on 'Calc_Ozone' and then on the right pane double click on 

'ScriptSource'. The script source code opens. 
 
7)  Right click on the text area and select 'Select all'. Right click again and select 'Paste'. The 

new script is copied from clipboard to the sounding data file. 
 
8)  Check that the last procedure in the script listing looks like this: 
 

PROCEDURE WriteTotalToDb 
   TotalCount -= 1 
   IF TotalCount < 0.5 
      SETDBDOUBLE(TotalPath$, "IntegratedOzone", Data+Residual) 
      SETDBDOUBLE(TotalPath$, "ResidualOzone", Residual) 
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      TotalCount = 5 
   ENDIF 
ENDPROCEDURE.  

 
9)  Click 'OK' to exit the script listing. 
 
10) Close DBManager by choosing 'Exit' is 'File' menu. The sounding data file is now updated 
and can be simulated to produce the total ozone data with the residual ozone included. 
 
 
6. QUESTIONS AND FEEDBACK 
 
If you have questions or comments, please send them to Vaisala helpdesk either by email to 
helpdesk@vaisala.com or by fax to +358-9-8949 2790. 
 


